Page 1 of 1

JfileUpload 2.9.1 'Invalid Credentials'

Posted: Wed Jul 02, 2014 12:24 am
by PhilH
We've had the enterprise 2.9.1 versions of JfileUpload, JbatchUpload, and sftp working fine for a year until recently. Attempts to transfer files now fail with an 'Invalid Credentials' error, even though the same credentials will authenticate fine using a stand alone sftp client. None of the code or libraries have changed, though the browsers (we use Firefox, Chrome and Internet Explorer) seem to have been updated to Java 1.7 from java 1.6.

I've tried different sftp servers with exactly the same result where transfering files with a stand alone sftp client works fine, but jfileupload fails to authenticate and therefore fails.

Is it possible there is an issue with using JfileUpload with Java 1.7? I've included part of the Java console output below in case that might shed some light...

Thanks in advance for any help you can offer....

[DEBUG] SFTPClient - Authentications that can continue: gssapi-with-mic,publickey,keyboard-interactive,password
[DEBUG] SFTPClient - Next authentication method: gssapi-with-mic
[DEBUG] SFTPClient - Authentications that can continue: publickey,keyboard-interactive,password
[DEBUG] SFTPClient - Next authentication method: publickey
[DEBUG] SFTPClient - Authentications that can continue: keyboard-interactive,password
[DEBUG] SFTPClient - Next authentication method: keyboard-interactive
cache: MemoryCache: removed entry
[DEBUG] SFTPClient - Authentications that can continue: password
[DEBUG] SFTPClient - Next authentication method: password
[DEBUG] SFTPClient - Disconnecting from port 22
[ERROR] SFTPClient - Auth fail <com.jcraft.jsch.JSchException: Auth fail>com.jcraft.jsch.JSchException: Auth fail
at com.jcraft.jsch.Session.connect(
at com.jcraft.jsch.Session.connect(
at jfileupload.transfer.client.sftp.SFTPClient.login(Unknown Source)
at jfileupload.transfer.client.ftp.FTPTransfer.connect(Unknown Source)
at jfileupload.transfer.client.ftp.FTPTransfer.FTPConnect(Unknown Source)
at Source)
at Source)

[DEBUG] FTPTransfer - Auth fail
[INFO] FTPUploadTransfer - Upload failed

Re: JfileUpload 2.9.1 'Invalid Credentials'

Posted: Sun Aug 24, 2014 12:39 pm
by support
Try to upgrade to JFileUpload 3.2